Curling 2.0

Curling 2.0题目:Curling2.0TimeLimit:1000MSMemoryLimit:65536KTotalSubmissions:22426Accepted:9102DescriptionOnPlanetMM-21,af

题目:

Curling 2.0
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22426   Accepted: 9102

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

Curling 2.0
Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.

Curling 2.0
Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

Curling 2.0
Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board


h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

Japan 2006 Domestic




心得:


不停地向四个方向试探,主要是递归,然后 递归后要恢复现场,接着换个方向 再来一次

另外就是,0x3f3f3f3这个数,这个数f的十进制是1061109567,也就是10^9级别的(和0x7fffffff一个数量级),而一般场合下的数据都是小于10^9的,所以它可以作为无穷大使用而不致出现数据大于无穷大的情形。

另一方面,由于一般的数据都不会大于10^9,所以当我们把无穷大加上一个数据时,它并不会溢出(这就满足了“无穷大加一个有穷的数依然是无穷大”),事实上0x3f3f3f3f+0x3f3f3f3f=2122219134,这非常大但却没有超过32-bit int的表示范围,所以0x3f3f3f3f还满足了我们“无穷大加无穷大还是无穷大”的需求。



代码:


#include<stdio.h>

void digui(int x,int y,int step);

int qiang(int x,int y);

int map[100][100];//定义地图

int minx;

int dx[4]= {0,1,0,-1};

int dy[4]= {1,0,-1,0};

int n,m;

int main()

{

    int i,j,k;

    int sx,sy;

    while(scanf(“%d%d”,&m,&n)!=EOF)

    {

        if(!n&&!m) break;

        for(i=0; i<n; i++) //输入地图

            for(j=0; j<m; j++)

            {

                scanf(“%d”,&map[i][j]);

                if(map[i][j]==2)//这是起点~

                {

                    sx=i;

                    sy=j;

                }

            }

        minx=0x3f3f3f3f;//设置一个“无穷大”

        digui(sx,sy,1);

        if(minx==0x3f3f3f3f)

            printf(“-1\n”);

        else

            printf(“%d\n”,minx);

    }

    return 0;

}

int qiang(int x,int y)//判定墙

{

    if(x>=0&&x<n&&y>=0&&y<m)

        return 1;

    return 0;

}

void digui(int x,int y,int step)//x,y是起点的坐标

{

//printf(“—\n”);

    if(step>10) return;

    for(int i=0; i<4; i++)

    {

        int nx=dx[i]+x;

        int ny=dy[i]+y;

        if(map[nx][ny]!=1&&qiang(nx,ny))//判断下一步是不是墙,如果是,则不能走 (紧挨的墙撞不动)

        {

            nx=x;

            ny=y;

            while(1)

            {

                nx+=dx[i];

                ny+=dy[i];

                if(!qiang(nx,ny)) break;

                if(map[nx][ny]==3)

                {

                    if(minx>step)

                        minx=step;

                    return;

                }

                if(map[nx][ny]==1)

                {

                    map[nx][ny]=0;

                    digui(nx-dx[i],ny-dy[i],step+1);//递归回去

                    map[nx][ny]=1;//恢复现场

                    break;//碰到墙后就得跳出循环了

                }

            }

        }

    }

}

AC截图:

Curling 2.0


今天的文章Curling 2.0分享到此就结束了,感谢您的阅读。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
如需转载请保留出处:https://bianchenghao.cn/63563.html

(0)
编程小号编程小号

相关推荐

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注