线段树区间修改复杂度_线段树区间修改

线段树区间修改复杂度_线段树区间修改InthegameofDotA,Pudge’smeathookisactuallythemosthorriblethingformostoftheheroes.Thehookismadeupofseveralconse

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.

让我们把钩子上连续的金属棒从1编号到n。每次操作,Pudge都可以把连续的金属棒从X编号到Y编号,改成铜棒、银棒或金棒。

钩的总值由N根金属棒的值之和计算。更精确地,每种杆的值计算如下:

每根铜棒的值为1。

每根银棒的价值是2。

每根金条的值是3。

Pudge想知道执行操作后钩子的总值。

你可以认为原来的钩子是由铜棒组成的。

#include<bits/stdc++.h> using namespace std; const int maxn=1e5+5; int sum[maxn<<2],lazy[maxn<<2]; void updata(int rt) { 
    sum[rt]=sum[rt<<1]+sum[rt<<1|1]; } void pushdown(int rt,int m)//区间更新,懒惰数组标记 { 
    if(lazy[rt]) { 
    lazy[rt<<1]=lazy[rt]; lazy[rt<<1|1]=lazy[rt]; sum[rt<<1]=lazy[rt]*(m-(m>>1));//左结点 sum[rt<<1|1]=lazy[rt]*(m>>1);//右结点 lazy[rt]=0; } } void build(int l,int r,int rt) { 
    lazy[rt]=0;//每个结点的lazy为0 if(l==r) { 
    sum[rt]=1;//说明到达叶子结点 return ; } int m=(r+l)>>1; build(l,m,rt<<1); build(m+1,r,rt<<1|1); updata(rt); } void update(int L,int R, int c, int l, int r, int rt) { 
    if(L<=l&&r<=R)//如果找到一个区间,直接更新区间的值 { 
    lazy[rt]=c;//lazy标记 sum[rt]=(int)c*(r-l+1); return ; } pushdown(rt,r-l+1);//更新区间内结点值 int m=(l+r)>>1; if(L<=m) update(L,R, c,l,m,rt<<1); if(R>m) update(L,R,c, m+1, r, rt<<1|1); updata(rt);//更新结点的值 } int main() { 
    ios::sync_with_stdio(false); int t; int a,b,c; int k = 1; cin>>t; while(t--) { 
    int n,m; cin>>n>>m; build(1,n,1); while(m--) { 
    cin>>a>>b>>c; update(a,b,c,1,n,1); } printf("Case %d: The total value of the hook is %d.\n", k++, sum[1]); } return 0; } 

今天的文章
线段树区间修改复杂度_线段树区间修改分享到此就结束了,感谢您的阅读。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
如需转载请保留出处:https://bianchenghao.cn/60717.html

(0)
编程小号编程小号

相关推荐

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注