Worms(水题)

Worms(水题)DescriptionItislunchtimeforMole.Hisfriend,Marmot,preparedhimanicegameforlunch.MarmotbroughtMolenorderedpiles

Description

It is lunch time for Mole. His friend, Marmot, prepared him a nice game for lunch.

Marmot brought Mole n ordered piles of worms such that i-th pile contains ai worms. He labeled all these worms with consecutive integers: worms in first pile are labeled with numbers 1 to a1, worms in second pile are labeled with numbers a1 + 1 to a1 + a2 and so on. See the example for a better understanding.

Mole can’t eat all the worms (Marmot brought a lot) and, as we all know, Mole is blind, so Marmot tells him the labels of the best juicy worms. Marmot will only give Mole a worm if Mole says correctly in which pile this worm is contained.

Poor Mole asks for your help. For all juicy worms said by Marmot, tell Mole the correct answers.

Input

The first line contains a single integer n (1 ≤ n ≤ 105), the number of piles.

The second line contains n integers a1, a2, …, an (1 ≤ ai ≤ 103, a1 + a2 + … + an ≤ 106), where ai is the number of worms in the i-th pile.

The third line contains single integer m (1 ≤ m ≤ 105), the number of juicy worms said by Marmot.

The fourth line contains m integers q1, q2, …, qm (1 ≤ qi ≤ a1 + a2 + … + an), the labels of the juicy worms.

Output

Print m lines to the standard output. The i-th line should contain an integer, representing the number of the pile where the worm labeled with the number qi is.

Sample Input

Input
5
2 7 3 4 9
3
1 25 11

Output
1
5
3

Sample Output

Hint

For the sample input:

  • The worms with labels from [1, 2] are in the first pile.
  • The worms with labels from [3, 9] are in the second pile.
  • The worms with labels from [10, 12] are in the third pile.
  • The worms with labels from [13, 16] are in the fourth pile.
  • The worms with labels from [17, 25] are in the fifth pile.

题意:第一行n为输入的区间数,第二行为N个区间的每个区间的长度,第三行m词询问,询问m个数在第几个区间里

ps:坑死了,TLE了四次,只因为数组没拿出来,到现在也没弄明白才10^6为嘛就要拿出来,飞神说超过1000的数组他就放在外面,以后就这么干了。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int num[1000010];
int main()
{
    int T,n,m,p;
    int i,j;
    int cnt=1;

    while(~scanf("%d",&T))
    {
        for(i=1; i<=T; i++)
        {
            scanf("%d",&n);
            for(j=1; j<=n; j++)
                num[cnt++]=i;
        }
        scanf("%d",&m);
        for(i=1; i<=m; i++)
        {
            scanf("%d",&p);
            printf("%d\n",num[p]);
        }
    }
    return 0;
}



今天的文章Worms(水题)分享到此就结束了,感谢您的阅读。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
如需转载请保留出处:https://bianchenghao.cn/63658.html

(0)
编程小号编程小号

相关推荐

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注