Tanning Salon
总提交:25 测试通过:17
描述
输入
The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.
输出
For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.
样例输入
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0
样例输出
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.
#include<iostream>
using std::cin;
using std::cout;
using std::endl;
#include<map>
using std::map;
#include<vector>
using std::vector;
#include<cstdlib>
#define NOT_FINISH 0
#define FINISHED 1
#define WAITING 2
#define PROCESSING 3
#define FINISHED_WAITING 4
#define FINISHED_PROCESSING 5
#define MAX 100000
int main(void){
unsigned int total;
while (cin >> total, total){
vector<char> line;
map<char, unsigned int> status;
unsigned int token = 0;
unsigned int leave = 0;
char list[MAX];
cin >> list;
for (char* it = list; *it != 0; ++it){
switch (status[*it]){
case NOT_FINISH:
if (token == total){ line.push_back(*it); status[*it] = WAITING; }
else{ status[*it] = PROCESSING; ++token; }
break;
case FINISHED:
if (token == total){ line.push_back(*it); status[*it] = FINISHED_WAITING; }
else{ status[*it] = FINISHED_PROCESSING; ++token; }
break;
case WAITING:
for (vector<char>::iterator vit = line.begin(); vit != line.end(); ++vit){
if (*vit == *it){line.erase(vit);status[*it] = NOT_FINISH;break;}
}
break;
case PROCESSING:
status[*it] = FINISHED;
if (line.empty()){ --token; }
else{ status[line.front()] = PROCESSING; line.erase(line.begin()); }
break;
case FINISHED_WAITING:
for (vector<char>::iterator vit = line.begin(); vit != line.end(); ++vit){
if (*vit == *it){line.erase(vit);status[*it] = FINISHED;break;}
}
break;
case FINISHED_PROCESSING:
status[*it] = FINISHED;
if (line.empty()){ --token; }
else{ status[line.front()] = PROCESSING; line.erase(line.begin()); }
break;
}
}
for (map<char, unsigned int>::const_iterator it = status.begin(); it != status.end(); ++it){
if (it->second != FINISHED){ ++leave; }
}
if (leave == 0) {
cout << "All customers tanned successfully." << endl;
}
else{
cout << leave << " customer(s) walked away." << endl;
}
}
return EXIT_SUCCESS;
}
今天的文章Tanning Salon分享到此就结束了,感谢您的阅读。
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
如需转载请保留出处:https://bianchenghao.cn/64192.html