题目描述
给出一棵n个节点的树,节点编号为1-n(根节点编号为1,且根节点深度为1),求这棵树的深度(树中节点的最大层次)。
例如:
1─2─4─5
└─3
其中1-2-4-5这条边是最长的,所以树的深度为4。
输入
第一行:1个数n(1 < n <= 1000),表示树的节点数量。
后面n-1行:每行2个数x y,表示节点x是节点y的父节点(1 <= x, y <= n)。
输出
输出1个数,表示这棵树的深度
输入样例
5
1 2
1 3
2 4
4 5
输出样例
4
代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll INF = 0x3f3f3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int MOD = 1e9+7;
const int MAX = 1e5+5;
int n;
vector <int> edge[MAX];
int maxDepth = 1;
void dfs(int id,int depth)
{
//cout << id << endl;
if(depth > maxDepth)
{
maxDepth = depth;
}
for(int i = 0; i < (int)edge[id].size(); i++)
{
dfs(edge[id][i],depth+1);
}
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
while(cin >> n)
{
int x,y;
for(int i = 0; i < n-1; i++)
{
cin >> x >> y;
edge[x].push_back(y);
}
maxDepth = 1;
dfs(1,1);
cout << maxDepth << endl;
}
return 0;
}
今天的文章51Nod 2282 树的深度 c/c++题解分享到此就结束了,感谢您的阅读。
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
如需转载请保留出处:https://bianchenghao.cn/68134.html