Highways_highway don t care[通俗易懂]

Highways_highway don t care[通俗易懂]TheislandnationofFlatopiaisperfectlyflat.Unfortunately,Flatopiahasaverypoorsystemofpublichighways.TheFlatopia

Highways_highway

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

这个题用vj提交,c++超时,g++就过了,很扎心,不是c++不容易超时吗?

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <cmath>
#include <list>
#include <queue>
#include <stack>
using namespace std;
const int maxn=751;
int N,M,x[maxn],y[maxn],mark[maxn*maxn];
struct node{
    int start,end;
    double cost;
};
bool cmp(node a,node b)
{
    return a.cost<b.cost;
}
node f[maxn*maxn];
double caculate(int x1,int y1,int x2,int y2)
{
    return sqrt(1.0*(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int find(int x)
{
    if(mark[x]==x)
        return x;
    else{
        mark[x]=find(mark[x]);
        return mark[x];
    }
}
void merge(int x,int y)
{
    int t1=find(x),t2=find(y);
    if(t1!=t2)
    {
        mark[t2]=t1;
    }
}
void init()
{
    for(int i=0;i<N;i++)
    {
        mark[i]=i;
    }
}
int main()
{   scanf("%d",&N);
    init();
    for(int i=1;i<=N;i++)
    {
        scanf("%d %d",&x[i],&y[i]);
    }
    int k=0;
    for(int i=1;i<N;i++)
    {
        for(int j=i+1;j<=N;j++)
        {
            f[++k].start=i;
            f[k].end=j;
            f[k].cost=caculate(x[i],y[i],x[j],y[j]);
        }
    }
    scanf("%d",&M);
    int a,b;
    for(int i=1;i<=M;i++)
    {
        scanf("%d %d",&a,&b);
        merge(a,b);
    }
    sort(f+1,f+k+1,cmp);
    for(int i=1;i<=k;i++)
    {
        if(find(f[i].start)!=find(f[i].end))
        {
            merge(f[i].start,f[i].end);
            printf("%d %d\n",f[i].start,f[i].end);
        }
    }
    return 0;
}

 

今天的文章Highways_highway don t care[通俗易懂]分享到此就结束了,感谢您的阅读。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。
如需转载请保留出处:https://bianchenghao.cn/69597.html

(0)
编程小号编程小号

相关推荐

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注